Rational Acoustics



Holger Stedem
June 18th, 2010, 04:28 AM
Hi,
now we are in version 7.0.5.1 and for my option the spl – measurement does not what it should do. When I use my calibrator to adjust my measurement unit it still does not behave like it should or like it does in Smaart 6.:mad:

What means:
I calibrate in the "Sound Level Option" window my system, then I go back to the RTH window to see the graph of the same input that I used to the calibration. Now in octave scale I expect a readout for the calibration frequenz with the same level as I calibrated, but the readout is about 4 dB less, in Smaart 6 it is similar.
What also annoys me about that topic is that there is no possibility to change the RTA- scale to the curent spl it just shows the full scale situation. Is there a planning to change this in the near future?

Holger

Harry Brill Jr.
June 21st, 2010, 01:43 AM
Need more details. What are you using for a calibrator?

When calibrating you are looking at just one frequency peak. When looking at pink noise, the frequencies are spread out. This is why the quick and dirty method isn't really acurate. There is the capability to enter an offset though.

Holger Stedem
June 21st, 2010, 02:16 AM
Hi Harry,
I use a calibrator with sinewave 1 kHz at 93 dB, it is a high class calibrator for acoustic measurement equipment.
I think it's definitely a failure in Smaart 7, as I wrote when I do exactly the same with Smaart 6 or 5, I get what I expect.
Holger

Calvert Dayton
June 21st, 2010, 06:26 PM
Hi Holger,

My first guess is you might not be giving the measurement enough time to stabilize before capturing your full-scale value. Either that, or you might calibrating with way too much background noise (electronic or acoustic). The former seems more likely though, since even if all your sidebands were down only 15 dB from the band at the calibrator frequency, that would only work out to about 3 dB difference between the two methods, assuming a 1/3-octave display. But if my guess is correct, just be sure to let the calibrator run for several seconds before capturing the dBFS value as you would when calibrating a standard SLM and that should take care of it. 10-15 seconds or so should do it.

Perhaps another possibly, if you were using a fractional octave banding narrower than 1/3-octave, is that older versions of Smaart did not follow the IEC standard for placing the center frequencies of fractional bands with even-numbered denominators but Smaart 7 does (so far). So while older versions of Smaart, always had a fractional octave band centered on 1k regardless of the fractional denominator, in version 7 that is an edge frequency for all fractional bands except 1- and 1/3-octave. If one happened to be using 1/6-octave resolution or higher and it escaped one's notice that two bars came up when the calibrator was switched on up instead of one, neither of which were centered on 1kHz, that might explain 3 dB of difference between Smaart 7 and an older version. Adam also flushed an unrelated bug in the new banding algorithm today that could possibly have been a small contributing factor, but again could not explain the kind of difference you were seeing by itself.

One more thing I might mention, just because you said you were doing your calibration at 94 dB (i.e., instead of 104 or 114) is that if you have an old-fashioned pistonphone calibrator or an acoustic calibrator that requires you to adjust the nominal output value for barometric pressure, you might actually still be better off doing your calibration in the frequency domain, based on a band-limited measurement the way we used to. That's easy enough to do by hand. Just subtract the full-scale value of the band at the calibrator frequency from the output value for the calibrator to get the required offset, then enter the result directly in the calibration offset field in the calibration dialog.

Most modern acoustical calibrators have a built in feedback circuit that automatically adjusts for air pressure and background noise to ensure that the nominal broadband SPL at the microphone capsule is correct within standard tolerances for the calibrator type. So if you have a more modern device you'll get a more accurate result by calibrating based on a broadband measurement, which is one of the reasons we switched to doing it in the time domain. But you're not the first person to have problems getting the right answer with the new method as the feature is currently designed, so we're also working on a couple of ideas to try and speed up the process and make it a little more obvious how to use it.

Holger Stedem
June 22nd, 2010, 08:59 AM
Hi Calvert
Sorry, but I think you did not get the point I talking about.
I'm not talking about any wired procedure to calibrate my system.
Anyway I expect, if I'm going to calibrate my system:
But a mic on, select the input, say the system what level is on the mic, push the calibration button, and than the work should be done.
And if a system can not do that, than for my opinion it is something wrong with the system itself.
But say I mentioned that's not the point.
I an old note from SIA-Soft, I don't find anymore, was written if you calibrate your System the readout in the level window and on the RTA graph would be the same when the graph shows an octave band scale.
With Smaar6 it is exactly that way.
With Saart7 it is not.
In a comparative measurement I did with my NTI AL1 you can see a total different behaviour.
Here the readout for graph and level are equal at a 1/3 octave scale.

With Smaart7 the difference is more than 1 dB 1/3O and 2 dB 1O.
With Smaart6 the difference is nearly nothing in both cases.

I just ask what system tells me the truth.


Holger

sweepableQ
June 22nd, 2010, 02:09 PM
Calvert,

I think a lot of us could benefit from a quick tutorial on calibrating the SPL measurement portion of SMAART 7.

Thanks,

Matt

Calvert Dayton
June 22nd, 2010, 05:05 PM
Sure, no problem:


Open the Amplitude Calibration dialog window by clicking CalibrateSound Level Options button in the dialog (Options > SPL/LEQ...).
Select the audio device and input channel that you want to calibrate.
Turn on your calibrator and wait a moment for the average to stabilize -- say 10-15 seconds for a microphone calibration using an SLC, maybe 20 to be on the safe side. 20 seconds would be enough time to build from -138.5 dB (all 0's in a 24-bit integer) to 0 dBFS (all 1's), given a 0 dBFS reference tone.
Click the Capture button.
Type your nominal reference level (e.g., 94, 104 or 114 dB) in the Calibrated Level field -- when performing a microphone calibration in the field you generally want to use the highest output level that your sound level calibrator offers.
Hit the Enter key to recalc the Calibration Offset.
Click the Apply button.
If you want to calibrate additional inputs, go back to step 2 and loop through again. Otherwise click the Done button to exit the dialog.

Calvert Dayton
June 22nd, 2010, 06:48 PM
Ah you know what? I take it back. All this time I was thinking you were complaining about SPL readings but on closer inspection, it looks like you're actually talking about the bug in the RTA banding algorithm that I mentioned yesterday. That's been found and fixed and hopefully the fix should be out later this week or early next.

But the entire problem in that case would be confined to just the RTA display values. SPL readings are unaffected. I can't actually tell from your screen shot if your SPL reading is calibrated correctly or not, but SPL measurement is completely independent of the RTA display. So assuming your input is properly calibrated (see my reply to Matt below) your SPL readings should be perfectly fine regardless of what the RTA says.

Harry Brill Jr.
June 22nd, 2010, 11:06 PM
Hi Harry,
I use a calibrator with sinewave 1 kHz at 93 dB, it is a high class calibrator for acoustic measurement equipment.
I think it's definitely a failure in Smaart 7, as I wrote when I do exactly the same with Smaart 6 or 5, I get what I expect.
Holger

OK thanks for the additional information.