Results 1 to 10 of 10
  1. Full SPL LEQ buffer causing high CPU usage

    #1

    Default Full SPL LEQ buffer causing high CPU usage

    As the title says, when the LEQ buffers are full I'm seeing an increase in CPU usage of around 30%. Resetting the LEQ buffers for that input drops the CPU usage back down. Anyone else seeing this?

    Mac Mini/Windows 10 running in Bootcamp
    i5-3210m @ 2.5ghz
    8gb RAM
    Smaart V8.2.3.1

  2. Re: Full SPL LEQ buffer causing high CPU usage

    #2

    Default

    Hey Nomarky,

    Are you logging, or just viewing one or more meters configured for Leq? Also, does the CPU usage increase only after the buffer is full, or does it increase while the buffer is filling? The latter is somewhat expected because of the nature of the calculation.
    Johnny A

    Rational Acoustics LLC
    860-928-7828
    www.rationalacoustics.com

  3. Re: Full SPL LEQ buffer causing high CPU usage

    #3

    Default

    Quote Originally Posted by Johnny View Post
    Hey Nomarky,

    Are you logging, or just viewing one or more meters configured for Leq? Also, does the CPU usage increase only after the buffer is full, or does it increase while the buffer is filling? The latter is somewhat expected because of the nature of the calculation.
    No logging, just two LEQ meters. CPU usage increases as the buffer is filling, then jumps to between 95 & 100% once the buffer is full

  4. Re: Full SPL LEQ buffer causing high CPU usage

    #4

    Default

    I'm not able to see any substantial increase or decrease in the CPU usage on my Windows computer here, but I don't have a Bootcamp setup to test on. Do you have another computer that's running Windows natively you can test with the same exact setup? My only guess at this point is that it's an optimization issue with Bootcamp combined with the dual-core processor.
    Johnny A

    Rational Acoustics LLC
    860-928-7828
    www.rationalacoustics.com

  5. Re: Full SPL LEQ buffer causing high CPU usage

    #5

    Default

    That rig is in the warehouse at the moment, it'll be a week or so before I go there and can move the license to my Windows laptop to test. Out of interest: I was thinking of upgrading the RAM to 16Gb, would that make any difference to this issue?

  6. Re: Full SPL LEQ buffer causing high CPU usage

    #6

    Default

    To avoid messing with your license, I would recommend downloading the demo from the link below and testing with that. I don't think that upgrading the RAM will help this particular problem, but it's always helpful in other areas.

    http://www.rationalacoustics.com/sma...d-smaart-demo/
    Johnny A

    Rational Acoustics LLC
    860-928-7828
    www.rationalacoustics.com

  7. Re: Full SPL LEQ buffer causing high CPU usage

    #7

    Default

    Quote Originally Posted by Johnny View Post
    To avoid messing with your license, I would recommend downloading the demo from the link below and testing with that. I don't think that upgrading the RAM will help this particular problem, but it's always helpful in other areas.

    http://www.rationalacoustics.com/sma...d-smaart-demo/
    Great, I will download the demo to test with next week and let you know how it goes

  8. Re: Full SPL LEQ buffer causing high CPU usage

    #8

    Default

    So I finally had a little time to look at this.

    I used the same soundcard setup as with the Mac Mini, but used the Smaart 8 demo running on my Dell XPS13.

    Smaart running on its own was taking up about 2% CPU. I then left it running a 15 minute LEQ. I noticed CPU had gone up to around 14% when I came back to it. Unfortunately I didn't get the chance to reset the LEQ buffer to see if this 'released' the CPU as a breaker tripped, powering off the Soundcard etc.

    I will try to test again next week, as this was test was a little inconclusive!

  9. Re: Full SPL LEQ buffer causing high CPU usage

    #9

    Default

    Quote Originally Posted by Nomarky View Post
    So I finally had a little time to look at this.

    I used the same soundcard setup as with the Mac Mini, but used the Smaart 8 demo running on my Dell XPS13.

    Smaart running on its own was taking up about 2% CPU. I then left it running a 15 minute LEQ. I noticed CPU had gone up to around 14% when I came back to it. Unfortunately I didn't get the chance to reset the LEQ buffer to see if this 'released' the CPU as a breaker tripped, powering off the Soundcard etc.

    I will try to test again next week, as this was test was a little inconclusive!
    I managed to try again. Whilst I could see a small increase of CPU whilst the LEQ was running on my Dell XPS13 I didn't see a decrease after resetting the LEQ buffer. I guess it must be a Bootcamp quirk. Thanks for taking the time to look into it!

  10. Re: Full SPL LEQ buffer causing high CPU usage

    #10
    Junior Member
    Join Date
    Jan 2019
    Posts
    4

    Default

    I'm not ready to perceive any considerable increment or decline in the CPU utilization on my Windows PC here, yet I don't have a Bootcamp setup to test on. Do you have another PC that is running Windows locally you can test with the equivalent correct setup? My solitary conjecture now is that it's an improvement issue with Bootcamp Bluestacks Kodi Lucky Patcher joined with the double center processor.
    Last edited by klimbo; January 24th, 2019 at 04:39 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •