Rational Acoustics



Johnny
April 5th, 2018, 04:03 PM
Smaart v8.3 Beta Rev 5365 is now available for download. This update includes the ability to control various settings on a Roland™ OCTA-CAPTURE™ via Smaart's Input Meters window, as well as fixes for various bugs and crashes.

For those of you already running the Beta build, you can update to the latest version using the built-in program updater by clicking File -> Check For Updates... within Smaart.


If you haven't installed the Beta in the past, you can download the installer from the "Downloads" page within your account at my.rationalacoustics.com.


The Beta Readme has been updated to include information about the new features and bug fixes, you can view it by clicking Help -> Beta Readme within Smaart or clicking the link below.


Release Notes


• Added control of the RolandTM OCTA-CAPTURETM1 to the Input Meters window

• Deleting windows from the Measurement Config tree now prompts you to keep or discard the window’s tabs

• Main application window can now be deleted from Measurement Config

• Configuration is now automatically saved when exiting the Configurator

• Fixed a bug where 10EaZy MAM display would reset after hide/show of SPL Meters window

• Fixed a bug where clicking the Spectrograph axis in IR Mode set the zoom range to something silly

• Fixed a bug where the Live IR plot would revert to default settings after toggling hide/show

• Fixed a crash that could occur when deleting a Tab


Beta Readme: http://my.rationalacoustics.com/downloads/Smaartv8BetaReadme.pdf

Niick
April 6th, 2018, 01:19 PM
Windows 7

Right Click on Saved trace, select info.
select color, select custom color
click on one of the 16 color swatch squares
select "set this swatch to the current colour"
Color swatch remains unchanged

Andy_Potvin
April 10th, 2018, 10:47 AM
I have experienced a surprising behavior with this Beta Version of SMAART:
I had configured a number of Tabs (7) each with a different number and type of measurement engines - a combination of Spectrum and Transfer Function.
I commenced a measurement session and after a switching from one tab containing 5 Spectrum measurement engines to a tab containing 5 TF measurement engines , upon returning to the initial tab the Spectrum measurement engines were not visible. Swapping back to the TF tab the measurement engines had disappeared there as well. All the measurement definitions are still present and correct in the measurement configuration window. I changed to another Tab with a similar/suitable measurement engine configuration and after an iteration of changing tabs the same behavior demonstrated itself.
I had to abandon the beta and return to the 8.2 distribution, which worked flawlessly. The one variable that may be most influential is that I am running 10.13.5. Beta (17F35e), however this OS beta did not impact the 8.2 Distribution.
Best Regards
Andy

Johnny
April 19th, 2018, 01:07 PM
Hey Andy!

Sorry for the delay, we were in Frankfurt last week. There were a few big dev tool updates that made it into the Beta, and I think this is related to that somehow. Can you send me (to my john@ email) your Beta Config from Documents/Smaart v8/Beta Config?

Daniel Ellis
April 24th, 2018, 09:45 AM
octacapture control isn't working for me. I see the controls but they don't track with the hardware. Is there some box I need to click somewhere that I'm missing to turn it on?

Johnny
April 25th, 2018, 09:20 AM
Daniel, do you have Roland's control panel open at the same time? If so, please close it and try again. There may be issues having both open on some computers, the messages get mixed up.

Daniel Ellis
April 25th, 2018, 11:15 AM
Roland control panel is not open. Rebooted a few times and nothing seems to change.

Mac OS 10.12.6
Octacapture driver 1.5.3
octacapture system version 1.5.1

Daniel Ellis
May 4th, 2018, 11:21 AM
any other ideas on this? I reinstalled the octacapture driver and nothing has changed for me. Bug?

Johnny
May 8th, 2018, 01:15 PM
Hi Daniel,

There's no trick to make it work, the controls should just appear in the Input Meters window and that's it. The control is achieved over MIDI, nothing special. Have you tried a different USB port/cable?

Daniel Ellis
May 8th, 2018, 11:19 PM
Not sure what's happening then. I reinstalled Smaart, Octacapture.. New USB cable, different port. The interface works fine and I see the controls on the meters but they won't control anything or show actual gain. It just shows 0 on every input. Could it be something in my MIDI setup?

Johnny
May 14th, 2018, 11:05 AM
Unfortunately I can't think of any other troubleshooting steps. We are communicating with the Octa in the same way as the Roland Control Panel, so if the control panel is working properly we should be as well. Do you have another computer you can try? OS X or Windows, doesn't matter. This should isolate the problem a bit.

Daniel Ellis
May 15th, 2018, 09:44 PM
well.. just tried it on another computer with windows and it worked great immediately.

Reinstalled Smaart Beta and Octacapture driver AGAIN on my mac and it still doesn't work. Hopefully it will work for me when the full release comes out.